2008年10月27日

カラープロファイル変更時のバグ

今回は単なる日記です。

GIMPの開発状況がなかなか楽しいことになっています。開発版を追いかけている人なら分かると思いますが、現時点で次のような変化がありました。

・オンキャンバステキスト機能 (GSoC2008のひとつ)
・ベクトルレイヤー機能の一部 (GSoC2006のひとつ)
・合成モードがGEGLに

このことをBlog記事に書こうとしてGIMPを使っていると、変な挙動があることに気がつきました。


以下、書き直した記事です。

とりあえず現時点で分かっている現象だけ書いておきます。
これの理由については分かっていません。

1. CMYKプロファイルの設定を「なし」にしておく
2. GIMPを(再)起動
3. ツールボックスの前景色(描画色)が黒(0,0,0)になっているのを確認する
4. 環境設定のカラーマネジメントでCMYKプロファイルにAdobe配布の「Japan Color 2001 Coated」を指定
5. ツールボックスの前景色(描画色)が(5,2,2)に変化

以下、4.でCMYKプロファイルを指定しなおすたびに5.の色がどんどん変化する
また、CMYKプロファイルを指定した状態でGIMPを新規起動したときのデフォルトの描画色が(0,0,0)にはならない。


上記の現象について、先日やまかわさんから”CMYKカラーセレクトモジュールを無効にした場合はどうか?”と指摘されました。同モジュールを削除してみたところ、問題の現象は発生しなくなりました。
これをBugzillaにバグ報告しておきました。
posted by いっちー at 20:15| Comment(4) | Dialy | 更新情報をチェックする
この記事へのコメント
日記と前置きされている記事にコメントするのも野暮かもしれませんが、ブレンドツールとカラーマネジメントの話がごっちゃになっていたり、検証の内容と結果の情報が不十分・あいまいなであるのに「GIMPのカラーマネジメントバグ」とか「CMYKプロファイルがこういった形で(しかも新規画像で)影響する、という実装方法は果たして正しいのでしょうか?」という書き方をするのは不適切であるように感じます。
時間があるようでしたら、ぜひ詳細な追試の記事を投稿していただきたいです。

ちなみに、この記事で分かる範囲の条件で試した限りは本来あるべき結果と異なる表示にはなりませんでした。
確認したのは、GIMP2.6.1(自前ビルド)、プラットフォームはWinXP ProとUbuntu 8.04です。
Posted by やまかわ at 2008年10月28日 20:54
コメントありがとうございます。
もし直接何か確認したいことがありましたら、IRCのほうにも顔を出しているのでよければどうぞ。


さらに調べてみると、最初に投稿した記事に書いてあることとは違う部分が原因であるようなので、記事の本文を書き直すことにします。


とりあえず現時点で分かっている現象だけ書いておきます。
これの理由については分かっていません。

1. CMYKプロファイルの設定を「なし」にしておく
2. GIMPを(再)起動
3. ツールボックスの前景色(描画色)が黒(0,0,0)になっているのを確認する
4. 環境設定のカラーマネジメントでCMYKプロファイルにAdobe配布の「Japan Color 2001 Coated」を指定
5. ツールボックスの前景色(描画色)が(5,2,2)に変化

以下、4.でCMYKプロファイルを指定しなおすたびに5.の色がどんどん変化する
また、CMYKプロファイルを指定した状態でGIMPを新規起動したときのデフォルトの描画色が(0,0,0)にはならない。
Posted by いっちー at 2008年10月29日 00:56
記事を読んで試しているうちに次のような現象を発見しました。
(この現象がすべての GIMP で起こるのか、私の GIMP のみの現象なのか分かりませんので、どなたか試験いただければ幸いです。)

GIMP のバージョンは 2.6.1 (svn rev.27449 ソースをビルド) OS は ubuntu 8.04 です。

環境設定のカラーマネジメントタブで 「ファイルを開くときの挙動」以外のいずれかを変更すると、その瞬間に描画色が変更されます。

この現象は次のようにして発見しました。

1.ツールボックスで描画色・背景色をリセット

2.描画色を変更ダイアログを開く。(描画色には HTML表記で "000000" が設定されている。)

3.環境設定ダイアログを開きカラーマネジメントタブで先に書いた項目のいずれかを変更すると、変更した瞬間に描画色が変わる。(HTML表記が変化)

変更された描画色の値は一定では無いようです。
Posted by nishbone at 2008年10月29日 01:34
このバグが修正されたようです。
https://bugzilla.gnome.org/show_bug.cgi?id=593848
Posted by いっちー at 2009年11月09日 01:59
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。